re = /Area="(?<Area>.*?)"(?=\]|,)/
str = '/MyData.csv(MemberCount.sum,Production.sum[Area="Europe "Area 1" (Germany)",Area="North America",Area="North America [Level A]"])'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end