$re = '~Area="(?<Area>.*?)"(?=\]|,)~';
$str = '/MyData.csv(MemberCount.sum,Production.sum[Area="Europe "Area 1" (Germany)",Area="North America",Area="North America [Level A]"])';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);