#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?=.*displayname)(?=.*templateid).*"
Local $sString = "<where>" & @CRLF & _
" <equals xmlns="http://xml.newview.com/sn/General/Expression">" & @CRLF & _
" <attribute displayname="document_status" templateid="556">NA_LOC_Location.system.document_status</attribute>" & @CRLF & _
" <value>'Active'</value>" & @CRLF & _
" </equals>" & @CRLF & _
"</where>" & @CRLF & _
"" & @CRLF & _
"<where>" & @CRLF & _
" <equals xmlns="http://xml.newview.com/sn/General/Expression">" & @CRLF & _
" <attribute templateid="556" displayname="document_status">NA_LOC_Location.system.document_status</attribute>" & @CRLF & _
" <value>'Active'</value>" & @CRLF & _
" </equals>" & @CRLF & _
"</where>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")