re = /(?=.*displayname)(?=.*templateid).*/
str = '<where>
<equals xmlns="http://xml.newview.com/sn/General/Expression">
<attribute displayname="document_status" templateid="556">NA_LOC_Location.system.document_status</attribute>
<value>\'Active\'</value>
</equals>
</where>
<where>
<equals xmlns="http://xml.newview.com/sn/General/Expression">
<attribute templateid="556" displayname="document_status">NA_LOC_Location.system.document_status</attribute>
<value>\'Active\'</value>
</equals>
</where>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end