const regex = /(?=.*displayname)(?=.*templateid).*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=.*displayname)(?=.*templateid).*', 'g')
const str = `<where>
<equals xmlns="http://xml.newview.com/sn/General/Expression">
<attribute displayname="document_status" templateid="556">NA_LOC_Location.system.document_status</attribute>
<value>'Active'</value>
</equals>
</where>
<where>
<equals xmlns="http://xml.newview.com/sn/General/Expression">
<attribute templateid="556" displayname="document_status">NA_LOC_Location.system.document_status</attribute>
<value>'Active'</value>
</equals>
</where>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}