package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\"[^\"]*\"`)
var str = `{
"type" : "object",
"properties" : {
"name" : {
"type" : "string"
},
"surname" : {
"type" : "string"
},
"children" : {
"type" : "array"
},
"address" : {
"type" : "object"
},
"appearance" : {
"type" : "object"
}
}
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}