$re = '/\"[^\"]*\"/';
$str = '{
"type" : "object",
"properties" : {
"name" : {
"type" : "string"
},
"surname" : {
"type" : "string"
},
"children" : {
"type" : "array"
},
"address" : {
"type" : "object"
},
"appearance" : {
"type" : "object"
}
}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);