import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"[^\\\"]*\\\"";
final String string = "{\n"
+ " \"type\" : \"object\", \n"
+ " \"properties\" : {\n"
+ " \"name\" : {\n"
+ " \"type\" : \"string\"\n"
+ " },\n"
+ " \"surname\" : {\n"
+ " \"type\" : \"string\" \n"
+ " },\n"
+ " \"children\" : {\n"
+ " \"type\" : \"array\"\n"
+ " },\n"
+ " \"address\" : {\n"
+ " \"type\" : \"object\"\n"
+ " },\n"
+ " \"appearance\" : {\n"
+ " \"type\" : \"object\"\n"
+ " }\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}