using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(uk_en)\b.*?\bneedle\b";
string input = @"id: page_name
locale: uk_en
----
<div> placeholder placeholder placeholder placeholder placeholder placeholder</div>
<span>placeholder placeholder placeholder placeholder placeholder placeholder </span>
<p>Needle</p>";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}