import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(uk_en)\\b.*?\\bneedle\\b";
final String string = "id: page_name\n"
+ "locale: uk_en\n"
+ "----\n"
+ "<div> placeholder placeholder placeholder placeholder placeholder placeholder</div>\n"
+ "<span>placeholder placeholder placeholder placeholder placeholder placeholder </span>\n"
+ "<p>Needle</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}