# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(uk_en)\b.*?\bneedle\b"
test_str = ("id: page_name\n"
"locale: uk_en\n"
"----\n"
"<div> placeholder placeholder placeholder placeholder placeholder placeholder</div>\n"
"<span>placeholder placeholder placeholder placeholder placeholder placeholder </span>\n"
"<p>Needle</p>")
matches = re.search(regex, test_str, re.DOTALL | re.IGNORECASE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.