import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(?:.*?May 2016){3}\\K.*?(?=Jun 2016)";
final String string = "May 2016 ef Jun 2016 efef May 2016 Jun 2016 May 2016\n\n"
+ "dffdg def efef\n\n"
+ "Jun 2016\n\n"
+ "May 2016\n\n"
+ "Jun 2016\n\n"
+ "foo bar\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}