re = /(?s)(?:.*?May 2016){3}\K.*?(?=Jun 2016)/
str = 'May 2016 ef Jun 2016 efef May 2016 Jun 2016 May 2016
dffdg def efef
Jun 2016
May 2016
Jun 2016
foo bar
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end