package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[01][0-9]|2[0-3])[0-5][0-9]$`)
var str = `0110
1110
1160
2040
1259
1643
2359
2400
2401`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}