$re = '/^(?:[01][0-9]|2[0-3])[0-5][0-9]$/m';
$str = '0110
1110
1160
2040
1259
1643
2359
2400
2401';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);