// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[01][0-9]|2[0-3])[0-5][0-9]$").unwrap();
let string = "0110
1110
1160
2040
1259
1643
2359
2400
2401";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}