using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Value=({[^{}]*(?1)?})";
string input = @"Key=key1,Value={""a="":""b""}, Key=key2,Value=value2, Key=key3,Value={""c"":{""d"":""e""}}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}