import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Value=(\\{[^\\{\\}]*(?1)?\\})";
final String string = "Key=key1,Value={\"a=\":\"b\"}, Key=key2,Value=value2, Key=key3,Value={\"c\":{\"d\":\"e\"}}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}