re = /Value=({[^{}]*(?1)?})/
str = 'Key=key1,Value={"a=":"b"}, Key=key2,Value=value2, Key=key3,Value={"c":{"d":"e"}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end