package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(
.* #match whatever characters that can be in a sentence
\? #match the question sign
){2,} #must occur two or more times`)
var str = `
1) What I love u? Look at me. Why I love u?
3) Why do you look at me?
4) Are you alright?
5) I am sick. How are you?. Well you do not have to answer it. what's up?
6) How are you? I am sick. What's up? Well you do not have to answer it.
7) Why I love u?
8) Any questions? No. Why not? Sure? Ok?
9) Jesus christ. You know what, do I love u? Look at me! Why I love u?
10) question mark '?' means question?\`\`
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}