import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\n"
+ ".* #match whatever characters that can be in a sentence\n"
+ "\\? #match the question sign\n"
+ "){2,} #must occur two or more times";
final String string = "\n"
+ "1) What I love u? Look at me. Why I love u?\n"
+ "3) Why do you look at me?\n"
+ "4) Are you alright?\n"
+ "5) I am sick. How are you?. Well you do not have to answer it. what's up?\n"
+ "6) How are you? I am sick. What's up? Well you do not have to answer it. \n"
+ "7) Why I love u?\n"
+ "8) Any questions? No. Why not? Sure? Ok?\n"
+ "9) Jesus christ. You know what, do I love u? Look at me! Why I love u?\n"
+ "10) question mark '?' means question?``\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}