import re
regex = re.compile(r"""
(
.* #match whatever characters that can be in a sentence
\? #match the question sign
){2,} #must occur two or more times
""", flags=re.VERBOSE)
test_str = ("\n"
"1) What I love u? Look at me. Why I love u?\n"
"3) Why do you look at me?\n"
"4) Are you alright?\n"
"5) I am sick. How are you?. Well you do not have to answer it. what's up?\n"
"6) How are you? I am sick. What's up? Well you do not have to answer it. \n"
"7) Why I love u?\n"
"8) Any questions? No. Why not? Sure? Ok?\n"
"9) Jesus christ. You know what, do I love u? Look at me! Why I love u?\n"
"10) question mark '?' means question?``\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")