const regex = /http:\/\/t.co\/[^\s]+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('http:\\\/\\\/t.co\\\/[^\\s]+', '')
const str = `Some text is better than one text http://t.co/blablabla #hashtag`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}