re = /http:\/\/t.co\/[^\s]+/
str = 'Some text is better than one text http://t.co/blablabla #hashtag'
# Print the match result
str.match(re) do |match|
puts match.to_s
end