$re = '/http:\/\/t.co\/[^\s]+/';
$str = 'Some text is better than one text http://t.co/blablabla #hashtag';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);