const regex = /(?|\{([^}]*)\}|\[([^]]*)\])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?|\\{([^}]*)\\}|\\[([^]]*)\\])', 'g')
const str = `[a1][a2]{a3}[b1][b2]{b3}[c1][c2]{c3}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}