# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([$@*&?]).*?\1(.*)/\2/g;t' <<< "$hahahaha$hahahaha hello
@hahahaha@hehehehe hello
?hahahaha?hihihihi hello
*hahahaha*hohohoho hello
&hahahaha&huhuhuhu hello"