import re
regex = re.compile(r"([$@*&?]).*?\1(.*)")
test_str = ("$hahahaha$hahahaha hello\n"
"@hahahaha@hehehehe hello\n"
"?hahahaha?hihihihi hello\n"
"*hahahaha*hohohoho hello\n"
"&hahahaha&huhuhuhu hello")
subst = "\\2"
result = regex.sub(subst, test_str)
if result:
print(result)