import Foundation
let pattern = #"([$@*&?]).*?\1(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
$hahahaha$hahahaha hello
@hahahaha@hehehehe hello
?hahahaha?hihihihi hello
*hahahaha*hohohoho hello
&hahahaha&huhuhuhu hello
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)