using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(feb\s[1-9][0-9]?)";
string input = @"1 2 3 the
the quick 2354
feb 1
feb 0
feb -10
feb23
feb 29
feb 3
february 10";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}