const regex = new RegExp('(feb\\s[1-9][0-9]?)', 'm')
const str = `1 2 3 the
the quick 2354
feb 1
feb 0
feb -10
feb23
feb 29
feb 3
february 10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}