import re
regex = re.compile(r"(feb\s[1-9][0-9]?)", flags=re.MULTILINE)
test_str = ("1 2 3 the\n"
"the quick 2354\n"
"feb 1 \n"
"feb 0\n"
"feb -10\n"
"feb23\n"
"feb 29\n"
"feb 3\n"
"february 10")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")