package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[1-9]\.\D\W`)
var str = `23434.13431.1234.
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}