$re = '/[1-9]\.\D\W/';
$str = '23434.13431.1234.
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);