#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<p[<>ib]*>([\w\s]+)<\/[\w]>"
Local $sString = "<html><head></head><body><p>Aa aa </p><p><b>Aa aa aa </b></p><p>Aa aa aa aa </p><p><i>Aa aa </i></p><p><b><i>B b b </i></b></p><b>Aa aa aa </b></body></html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")