re = /<p[<>ib]*>([\w\s]+)<\/[\w]>/
str = '<html><head></head><body><p>Aa aa </p><p><b>Aa aa aa </b></p><p>Aa aa aa aa </p><p><i>Aa aa </i></p><p><b><i>B b b </i></b></p><b>Aa aa aa </b></body></html>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end