using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"med venlig hilsen| hilsn?e?r?n?|(met)? (vriendelijke|hartelijke)? groe?te?n?|terveisin| h[ä|a]lsninga?r?| kveðja";
string input = @" met vriendelijke groten";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}