const regex = new RegExp('med venlig hilsen| hilsn?e?r?n?|(met)? (vriendelijke|hartelijke)? groe?te?n?|terveisin| h[ä|a]lsninga?r?| kveðja', 'i')
const str = ` met vriendelijke groten`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}