import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:V\\d{1,2}\\.\\d{1,2})|(?:\\d{1,3}\\.\\d{1,2})|(?:E\\d{1,2}\\.\\d+))(?!\\d|(?:\\s*(?:kg|lb|mg)s?))";
final String string = "134.57 or V23.54 or E33.62 134.57 lb or a lab result like 127.20 mg/dL";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}