re = /(?:(?:V\d{1,2}\.\d{1,2})|(?:\d{1,3}\.\d{1,2})|(?:E\d{1,2}\.\d+))(?!\d|(?:\s*(?:kg|lb|mg)s?))/i
str = '134.57 or V23.54 or E33.62 134.57 lb or a lab result like 127.20 mg/dL'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end