const regex = /(?:(?:V\d{1,2}\.\d{1,2})|(?:\d{1,3}\.\d{1,2})|(?:E\d{1,2}\.\d+))(?!\d|(?:\s*(?:kg|lb|mg)s?))/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:V\\d{1,2}\\.\\d{1,2})|(?:\\d{1,3}\\.\\d{1,2})|(?:E\\d{1,2}\\.\\d+))(?!\\d|(?:\\s*(?:kg|lb|mg)s?))', 'gi')
const str = `134.57 or V23.54 or E33.62 134.57 lb or a lab result like 127.20 mg/dL`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}