using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?(https?\:\/\/[^\"" ]+)";
string input = @"lorem ipsum http://google.com lorem ipusm dolor http://yahoo.com/something";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}