package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^.*?(https?\:\/\/[^\" ]+)`)
var str = `lorem ipsum http://google.com lorem ipusm dolor http://yahoo.com/something`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}