re = /^.*?(https?\:\/\/[^\" ]+)/
str = 'lorem ipsum http://google.com lorem ipusm dolor http://yahoo.com/something'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end