package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(.+?)\s(\d+\.\d*\".*)`)
var str = `Tony Hawk 39.75" x 8.75"
AD-37 8.0"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}