// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)(.+?)\s(\d+\.\d*\".*)"#).unwrap();
let string = "Tony Hawk 39.75\" x 8.75\"
AD-37 8.0\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}