#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=.*[0-9])(?=.*[a-z])^[a-z0-9]{5,15}$"
Local $sString = "lol" & @CRLF & _
"woooow" & @CRLF & _
"loooooooool4" & @CRLF & _
"looooooooooooooooooooool" & @CRLF & _
"loooooo4444444ooooooooooooool" & @CRLF & _
"444444444" & @CRLF & _
"lol4lol" & @CRLF & _
"lol4lol4lol"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")