using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*[0-9])(?=.*[a-z])^[a-z0-9]{5,15}$";
string input = @"lol
woooow
loooooooool4
looooooooooooooooooooool
loooooo4444444ooooooooooooool
444444444
lol4lol
lol4lol4lol";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}