$re = '/(?=.*[0-9])(?=.*[a-z])^[a-z0-9]{5,15}$/m';
$str = 'lol
woooow
loooooooool4
looooooooooooooooooooool
loooooo4444444ooooooooooooool
444444444
lol4lol
lol4lol4lol';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);