import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=(;\\d{4}-\\d\\d-\\d\\d\\n))((?:[^;]++|;)*?)\\1";
final String string = "№;Задача;T;O;P\n"
+ ";2016-01-18\n"
+ "1. ;task1;03:00;.; \n"
+ ";2016-01-18\n"
+ "2. ;task2;03:00;.; \n"
+ ";2016-01-18\n"
+ "3. ;task3;03:00;.; \n"
+ ";2016-01-19\n"
+ "7. ;33333;03:00;.; \n"
+ ";2016-01-19\n"
+ "8. ;d;03:00;.; \n"
+ ";2016-01-19\n"
+ "9. ;00;03:00;.; \n"
+ ";2016-01-20\n"
+ "21. ;task1;03:00;.; \n"
+ ";2016-01-20\n"
+ "22. ;task2;03:00;.; \n"
+ ";2016-01-21\n"
+ "25. ;testtime;03:00;.; \n"
+ ";2016-01-21\n"
+ "26. ;fgghgfh;23:45;.;, new t.";
final String subst = "\\2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}